Dell Vostro 1500 ‘Set up couldn’t find any drivers to match your hardware’

I had to re-install the operating system(Windows XP) on a Dell Vostro 1500, all drivers installed without a problem except for the nVidia driver needed for the on-board nVidia GeForce 8600M. The driver 175.97 xp WHQL, A08 failed to install and all attempts resulted in this error:

Set up couldn’t find any drivers to match your hardware

Remember this is the recommended driver by Dell and I could not afford to ignore the error since the missing driver made the laptop seem slow.


The only solution at the moment is to download the previous version of the recommended driver from the Dell site. Just visit the Dell Driver and Download page click on the recommended driver and then search for and click on Other Versions. This will open a new window where you will be presented with all previous drivers.

The driver that work for my Dell Vostro 1500 was 179.24 XP, A10.


  • pplepieu

    I have the exact same problem withGeForce 8400M GS in a Vostro 1700 clean xp pro32 , I get message:
    ” Set up couldn’t find any drivers to match your hardware” After trying to install the driver :
    175.97 xp WHQL, A08 R190066.exe
    All new drivers , installed in proper order…….
    Does anybody have some suggestions?
    Also did someone have any luck with those drivers:

    156.83_xp WHQL, A06 R173730.exe

    or same videocard but Inspiron 1720 series:
    174.31 xp WHQL, A07 R180917.exe

    or same videocard but from nvidia website, desktop

    My original driver is: I think it is,on dell website aka : 156.65 WHQL, A05 R168180.EXE